
Guide to LATEX Dr. Jimmy Doi

These notes are based on a tutorial created by Dr. Marie Davidian at NC State University.

WHAT IS LATEX?

LaTeX (pronounced “lay-tek” or “lah-tek”) is a language created for the purpose of typesetting text and
mathematical formulas.

What LATEX is NOT:

• A word-processor that allows the user to view a document as it is created in a “what you see is what
you get” format (e.g., MS-Word)

• A word-processor associated with a certain operating system (e.g., Windows)

• A word-processor in which creation of highly technical mathematical content is a big pain in the neck

• A product that the user must purchase

What LATEX IS:

• A freely-available, powerful typesetting language

• Supremely well-suited to creation of documents with heavy technical and mathematical content

• The standard typesetting language used by major publishers of books in the sciences (e.g., Springer,
CRC Press, Wiley, etc.)

• The standard typesetting language used by most journals in the sciences (including Journal of the
American Statistical Association, Biometrics, etc.)

What LATEX IS:

• The popular way to produce a dissertation document.

• A useful way to typeset homework assignments, reports, posters, conference presentations, and of
course the senior project.

• Versions available for UNIX, Linux, Windows, Mac, etc.

• The overwhelming choice of most people in math, statistics, physics, computer science, engineering,
and many other disciplines to produce articles, reports, books, letters, visual presentation materials,
and more
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What a typical LATEX session looks like:

[16 points total] Suppose the density function for Y is given by

h(y) =

{
kye−y/β, 0 < y

0, otherwise
.

Here, β is a positive constant.
Find the value of k which makes h a valid density (express your answer in terms of β). Show all work
and mathematical justifications. You may use the back of this sheet if you need more space.
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Structure of a .tex file:

• Preamble

– Specify document class (article, report, book, letter, etc.)

– Add any “packages” used (e.g., to import graphics, create headers and footers, etc.)

– Specify margins, indentation, spacing, etc.

– Define “new commands” (coming up. . . )

• Document body

– The actual document content

For example: Here is a sample preamble and document body for an article.

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

% Sample LaTeX Document

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

% Font sizes: 10pt, 11pt, 12pt

% Doc style: article, book, ...

\documentclass[12pt]{article}

% TONS of packages available

% to suit your particular needs

\usepackage{graphicx}

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

% The Preamble

% - Adjust page "setlength" values

% to work with your environment

\setlength{\oddsidemargin}{0.0in}

\setlength{\evensidemargin}{0.0in}

\setlength{\topmargin}{0.5in}

\setlength{\headheight}{0.20in}

\setlength{\headsep}{3ex}

\setlength{\parskip}{2.3ex}

\setlength{\parindent}{0.0in}

\setlength{\baselineskip}{2ex}

\setlength{\textheight}{9in}

\setlength{\textwidth}{6.5in}

% - Add other customizations above

% as needed (esp. "newcommand")

%

% The Preamble

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

\begin{document}

\section{Introduction}

This is the introduction ...

% Lots of impressive math

% expressions to be found here!

\end{document}
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Some important notes:

• % symbol is used to document the file or “comment out” text; anything to the right of a % does not
appear in the document

• LATEX commands start with \

• LATEX is case sensitive

• To obtain, for example, a 1 inch margin on all sides for your output, appropriate values for the
various \setlength statements will depend on your particular computer and printer (experiment
with various settings)

MODES AND ENVIRONMENTS

Modes: At any point in a LATEX file, there is a current “mode” in effect

• Paragraph mode – the default text mode, with line wrap. A space between lines signals the start of
a new paragraph

• Math mode – math symbols and commands may be used, and mathematical expressions result

• LR mode – “left-to-right” mode, lines do not automatically wrap around

Note on math mode: Math symbols and commands only work in math mode; if they are used in other
modes, an error will result

Environments: Often, there is also an environment in effect that determines how material is displayed –
the basic structure is

\begin{environment-name}

...

\end{environment-name}

For example: The math environment

the linear model \begin{math}Y = X\beta + \epsilon\end{math}.

the linear model Y = Xβ + ε.
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• The popular shortcuts are to use $ ... $ or \( ... \), e.g.

the linear model $Y = X\beta + \epsilon$.

the linear model Y = Xβ + ε.

MAKING LISTS

For example: Creating a numbered list

\begin{enumerate}

\item This is the first entry

\item This is the second entry

\item This is the third entry

\end{enumerate}

1. This is the first entry

2. This is the second entry

3. This is the third entry

For example: Creating a bulleted list

\begin{itemize}

\item This is the first entry

\item This is the second entry

\item This is the third entry

\end{itemize}

• This is the first entry

• This is the second entry

• This is the third entry

TEXT EXPRESSIONS AND SIZES

\underline{Sample} =⇒ Sample
\textbf{Sample} =⇒ Sample
\emph{Sample} =⇒ Sample

\textit{Sample} =⇒ Sample
\textsl{Sample} =⇒ Sample
\textsc{Sample} =⇒ Sample
\texttt{Sample} =⇒ Sample

Compositions
\underline{\textbf{Sample}} =⇒ Sample

\emph{\textbf{Sample}} =⇒ Sample
\underline{\textsc{Sample}} =⇒ Sample

\tiny Sample =⇒ Sample

\scriptsize Sample =⇒ Sample

\footnotesize Sample =⇒ Sample
\small Sample =⇒ Sample

\normalsize Sample =⇒ Sample
\large Sample =⇒ Sample
\Large Sample =⇒ Sample
\LARGE Sample =⇒ Sample
\huge Sample =⇒ Sample
\Huge Sample =⇒ Sample
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MATH EXPRESSIONS

• Roots, subscripts, superscripts

\sqrt{x+y}, x_{ij}, e^y, \sum^n_{i=1}

√
x + y, xij, e

y,
∑n

i=1

• Greek

\alpha,\beta,\gamma,\delta,\epsilon,\eta,\theta,\lambda

α, β, γ, δ, ε, η, θ, λ

\Gamma,\Delta,\Theta,\Lambda,\Omega,\Sigma

Γ, ∆, Θ, Λ, Ω, Σ

• Roofs

\hat{\alpha},\tilde{\alpha},\dot{x},\overline{x},\bar{x}

α̂, α̃, ẋ, x, x

• Binary operations

\pm,\times,\div,\cup,\otimes

±,×,÷,∪,⊗

• Relation symbols

\leq,\subset,\in,\geq,\equiv,\sim,\approx,\neq,\perp

≤,⊂,∈,≥,≡,∼,≈, 6=,⊥

• Arrows

\rightarrow,\Leftarrow,\Leftrightarrow,\uparrow

→,⇐,⇔, ↑

• Miscellaneous

\forall,\exists,\Re,\sum,\prod,\int

∀,∃,<,
∑

,
∏

,
∫
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Math, continued: textstyle vs. displaystyle

• Math displayed as equations may be carried out using the displaymath, equation, eqnarray*,
eqnarray environments

• Shortcuts when equations are not numbered: $$ ... $$ or \[ ... \]; e.g.,

$$\sum^n_{i=1} x_i^2 (Y_{ij}-z_i \beta)$$

n∑
i=1

x2
i (Yij − ziβ)

• Some symbols appear differently depending on whether they are in the text or displayed; e.g.,

$\sum^n_{i=1}$ VS. $$\sum^n_{i=1}$$

∑n
i=1 VS.

n∑
i=1

• Can be overridden with textstyle{ } and \displaystyle{ }

• Products, integrals, unions

$$\prod^n_{j=1},\hspace{0.1in} \int^\infty_t f(u) du,

\hspace{0.1in}\bigcup_{A: A \in \Omega}$$

n∏
j=1

,

∫ ∞

t

f(u)du,
⋃

A:A∈Ω

• Special functions

$\exp(x), \log y, \sin(k\pi), \min_x f(x)$

exp(x), log y, sin(kπ), minx f(x)

• Fractions, partial derivatives

$$\frac{\exp(x^T \beta)}{1+\exp(x^T \beta)},

\frac{\partial u}{\partial x}$$

exp(xT β)

1 + exp(xT β)
,
∂u

∂x

Note: Use \displaystyle for fractions; otherwise they are too small
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Math, continued: There are different ways to present math in boldface; here are two

• $\mbox{\boldmath $X$}$, $\mbox{\boldmath $\Sigma$}$

X, Σ

• $\mathbf{X}$, $\mathbf{\Sigma}$

X, Σ

Math, continued: array and eqnarray environments

• (2× 3) matrix:

\left( \begin{array}{ccc}

x_{11} & x_{12} & x_{13}\\

x_{21} & x_{22} & x_{23} \end{array} \right)(
x11 x12 x13

x21 x22 x23

)
• Determinant of (2× 2) matrix:

\left| \begin{array}{cc}

a_{11} & a_{12} \\

a_{21} & a_{22} \end{array} \right|∣∣∣∣ a11 a12

a21 a22

∣∣∣∣
• Braces

f_X(x)= \left\{ \begin{array}{cl}

\theta x^{\theta -1}, & 0<x<1\\

0, & \mbox{otherwise} \\

\end{array} \right.

fX(x) =

{
θxθ−1, 0 < x < 1

0, otherwise.

• Binomial coefficients: With the package statement \usepackage{amssymb,amsmath} (to be discussed
later) we can create “n choose k” easily:

{n \choose k} (
n

k

)

Math, continued: array and eqnarray environments

• Equation with several lines, = signs lined up
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\begin{eqnarray*}
\Delta_i & = & \sum_j \sum_{k \neq j} \mbox{Corr}(Y_{ij},Y_{ik}) \\
& = & \sum_j \sum_{k \neq j} \rho_i^{\parallel j-k \parallel} \\
& = & \frac{2 \rho_i}{1-\rho_i} \left\{ n_i-1 -

\frac{\rho_i(1-\rho_i^{n_i-1})}{1-\rho_i} \right\}
\end{eqnarray*}

∆i =
∑

j

∑
k 6=j

Corr(Yij, Yik)

=
∑

j

∑
k 6=j

ρ
‖j−k‖
i

=
2ρi

1− ρi

{
ni − 1− ρi(1− ρni−1

i )

1− ρi

}

The tabular environment:

• As with array, separate elements with &, make new line with \\

• Specify number of columns and type of justification at top, add vertical and horizontal lines

\begin{tabular}{|ccc|} \hline
$X$ & $Y$ & $Z$\\ \hline
1 & 2 & 12\\
2 & 4 & 14\\
3 & 6 & 15\\
4 & 8 & 20\\ \hline
\end{tabular}

X Y Z
1 2 12
2 4 14
3 6 15
4 8 20

\begin{tabular}{c|rr}
& \multicolumn{2}{c}{Results} \\
Parameter & Bias & SE \\
\hline
$\beta_0$ & $-$0.030 & 0.12 \\
$\beta_1$ & 0.002 & 0.07
\end{tabular}

Results
Parameter Bias SE

β0 −0.030 0.12
β1 0.002 0.07
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NEWCOMMANDS

Motivation: In technical typing, the same (nasty) expression may appear frequently

• A newcommand is like a “shortcut” to produce the expression easily

• \newcommand{keyword}{text}

• A newcommand declaration may appear anywhere in a LATEX source file (preamble or body) and is
defined thereafter

• A newcommand keyword may not contain numbers

Examples: Some newcommand definitions and their usage

\newcommand{\bbeta}{\mbox{\boldmath $\beta$}}
\newcommand{\betahatj}{\widehat{\bbeta}_j}
\newcommand{\var}{\mbox{var}}
\newcommand{\sumjn}{\sum^n_{j=1}}
\newcommand{\npdf}{\frac{1}{\sqrt{2\pi}\sigma}e^{-(x-\mu)^2/2\sigma^2}}

• The following text leads to a convenient shortcut:

the density of $X$ is given by $\npdf$

the density of X is given by 1√
2πσ

e−(x−µ)2/2σ2

• Note that a previously-defined newcommand may be used in defining a new newcommand

$$\sumjn \var(\betahatj)$$

n∑
j=1

var(β̂j)
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CROSS REFERENCES

Advantage: A built-in feature of LATEX is that it automatically keeps track of sections, numbered equa-
tions, pages, and so on

• Sections, equations, tables, figures, pages etc. may be labeled and referred to by the label

• If new labeled entities are added, LATEX renumbers them automatically

• It is even possible to generate a table of contents and index for a document

• To set up cross references correctly, must compile a document twice

LaTeX Warning: Label(s) may have changed. Rerun to get cross-references right.

Examples:

• Numbered equation

\begin{equation}

\var(\alpha) = \sumjn \var(\betahatj)

\label{eq:alpha}

\end{equation}

In equation~\ref{eq:alpha}, we see that...

var(α) =
n∑

j=1

var(β̂j) (0.1)

In equation 0.1, we see that...

Examples, continued:

• Section label

\section{Introduction}

\label{s:intro}

...As discussed in Section~\ref{s:intro}, kurtosis...
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• Page label

Thus, we see that calculation of the variance is

straightforward \label{p:var}

...On page~\pageref{p:var}, the variance calculation...

PACKAGES

Useful utilities: LATEX is much more powerful than the intrinsic features would suggest

• A huge user community

• Contributed document classes, “add-ons” to allow different capabilities and customization

• “Packages”

• Define new commands, syntax, etc.

• Visit CTAN (see page 15)

IMPORTING GRAPHICS

Numerous options: We discuss three of these

• psfig – \usepackage{psfig}

\psfig{figure=C:/images/mygraphic.ps,height=2.5in}

• epsf – \usepackage{epsf}

\epsfysize=2.5in

\epsfbox{C:/images/mygraphic.ps}

• graphicx – \usepackage{graphicx}

• Can also import other formats (pdf, jpg, png, etc)

\includegraphics[height=2.5in]{C:/images/mygraphic.ps}
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TABLES AND FIGURES

Two standard LATEX environments: table and figure

• Automatically numbers tables and figures

• Allow tables and figures to be formatted and referenced within a document

• Allow captions

\begin{table}[h]
\begin{center}
\begin{tabular}{c|rr}
& \multicolumn{2}{c}{Results} \\
Parameter & \multicolumn{1}{c}{Bias} & \multicolumn{1}{c}{SE} \\
\hline
$\beta_0$ & 0.030 & 0.12 \\
$\beta_1$ & 0.002 & 0.07
\end{tabular}
\end{center}
\caption{\it Results of the simulation>}
\label{t:simresults}
\end{table}

Results
Parameter Bias SE

β0 0.030 0.12
β1 0.002 0.07

Table 1: Results of the simulation.

• Reference – In Table~\ref{t:simresults}, we see that...

• In Table 1, we see that. . .
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\begin{figure}

\caption{\it Normal Approximation to Binomial}

\label{f:norm_appx}

\begin{center}

\includegraphics[height=2.5in]{C:/images/norm_bin2.pdf}

\end{center}

\end{figure}

Figure 1: Normal Approximation to Binomial
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• Reference – In Figure~\ref{f:norm_appx}, we see that...

• In Figure 1, we see that. . .
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WHERE TO LEARN MORE

Books and guides:

• Lamport, L. (1994) LATEX: A Documentation Preparation System, User’s Guide and Reference Man-
ual (The creator of LATEX)

• Goossens, M. et al. (1994) The LATEX Companion

• Kopka, H. (1999) A Guide to LATEX : Document Preparation for Beginners & Advanced Users

• Hahn, J. (1993) LATEX for Everyone: A Reference Guide and Tutorial for Typesetting Documents
Using a Computer

• Oetiker, T. et al. (2002) The Not So Short Introduction to LATEX 2ε (Widely available online)

• Cal Poly Statistics Faculty (Anytime) A very accessible group of individuals with extensive experience
in LATEX. One of the best ways to learn LATEXis to see sample code from other users ... feel free to
ask for help!

Resources online and on the Web:

• The Comprehensive TEX Archive Network (CTAN) www.ctan.org – a repository of tons of style
files, packages, etc.

• Tutorial at NCSU www.stat.ncsu.edu/computing/howto/latex/session 1/ – for UNIX/LINUX
focus

• Google ‘Groups’ groups.google.com – Search site with keywords ... many answers available here!

• TeXnic Center toolscenter.org – Freeware text editor specifically for LATEX

• Crimson Editor crimsoneditor.com – Freeware text editor – great for editing LATEX, SAS, Splus,
C++, ...

• Tex FAQ Site www.tex.ac.uk/faq
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SOFTWARE DISCUSSION

We will be using MikTeX as the LATEX ‘engine’ which compiles the file containing the LATEX code. TeXnic
Center will be the program we use to edit the LATEX code files. Any text editor can be used to edit the
file, but TeXnic Center is useful since it can be customized to conveniently launch commands to compile
and view your document. Another nice feature about TeXnic Center is that it is freeware!

Installing the software from the CDROM

A CDROM containing the necessary programs to work on LATEX on your home computer will be available
from the Stat Lab. Please be sure to return the CDROM when you are finished.

1. MikTeX: Go into the MikTeX directory on the CDROM and double click setup.exe. If your hard
drive has limited space, install using the minimal install option. If you have sufficient space, the full
install is helpful since it contains just about all the extra features (especially ‘packages’) you will
ever need. The full install requires 400 – 500 MB.

2. Ghostview: Go into the Ghostview directory on the CDROM and double click (one at a time) the
two .exe files you will find. Both programs are needed to view and print ‘postscript’ format files.
Accept the default directories suggested through the installation process.

3. Acroread: Go into the Acroread directory on the CDROM and double click the .exe file to install
Adobe Reader (to read PDF files). Accept the default directories suggested through the installation
process.

4. TeXnic Center: Go into the TeXnic Center directory on the CDROM and double click on the .exe
file.

1 Simple LATEX Session: Using the DVI Viewer

• Most simple way to run a session

• Swap back and forth between text editor and the DVI viewer

• When ready to print your finished product, convert the file into either a ‘postscript’ or ‘PDF’ format
and print using the appropriate application (see below).

2 LATEX Session: Postscript Method

• Swap back and forth between the text editor and Ghostview which is a postscript file application

• Involves an extra step where the file is first compiled with LATEX , then converted to postscript format,
and then finally viewed with Ghostview

• Use the Postscript method if importing postscript graphic images

• Use Ghostview to print your finished product
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3 LATEX Session: PDF Method

• Swap back and forth between the text editor and Adobe Reader which is a PDF file application

• Involves an extra step where the file is first compiled with LATEX , then converted to PDF, and then
finally viewed with Adobe Reader

• Use the PDF method if importing JPG or PNG graphic images

• Use Adobe Reader to print your finished product

You can run into many problems trying to import jpg format images through the postscript instructions
given above.

4 Using TeXnic Center

• Choose one of the methods above (DVI, PS, PDF) by selecting the appropriate option from the
toolbar:

• To compile the LATEX file, click on the icon from the toolbar above, use the default hotkey combo
[Ctrl+F7], or go to the menu and choose Build -> Current File -> Build:
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• To view the converted (DVI,PS,PDF), click on the icon from the toolbar above, use the default
hotkey combo [F5], or go to the menu and choose Build -> View Output:

• To compile and view the in one step (combining both steps above), click on the icon from the
toolbar above, click on the default hotkey combo [ ], or go to the menu and choose Build ->

Current File -> Build and View:

• Customizations: Choose Tools -> Customize to access some convenient options –

– Toolbars – Add/remove any particular buttons on the toolbar

– Keyboard – Make your own hotkey combinations for special functions (such as those functions
above)

• Block Commenting/Uncommenting – Under the Edit menu, use the option to comment/uncomment
rows of your LATEXcode to help in debugging (very useful!)

• Spell Check – choose Tools -> Spelling to do a check on spelling before printing the final product!
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